#1  
Old 14-05-2024, 06:02 PM
carlstronomy (Carl)
Registered User

carlstronomy is offline
 
Join Date: May 2012
Location: Brisbane
Posts: 461
EQDIRECT Cable

Evening fellow stargazers.

I made my own EQDIRECT cable myself for my NEQ6 many years ago. It works well but got a little wet and is a tiny bit rust on the USB connector.

I decided to purchase a ready made cable but at the same time decided to get a 5 meter version so I could remove my USB hub.

So I connected it up tonight and gave it a try. The communications are very slow and it also times out which is not good, it can not stay connected for more than 1 minute. All setting in EQMOD and Windows are correct. It does talk just not well, as soon as I plug my old cable in everything is fine stable and runs like a dream.

Does anyone know of this issue with the longer cables or maybe it is the brand.

Should I increase the baud rate form 9600 to allow for the extra distance, this will not increase the strength but speed the transfer up.

Item Astro Force Shoestring 5M FTDI EQDIR USB adaptor for SW EQ6 or NEQ6

Any assistance would be great.

Thanks
Carl
Reply With Quote
  #2  
Old 14-05-2024, 07:14 PM
iborg's Avatar
iborg (Philip)
Registered User

iborg is offline
 
Join Date: Feb 2015
Location: Lynbrook, Australia
Posts: 637
Hi Carl


I recently had an issue with a long cable, that had previously been working. Using a shorter cable in my case was the only viable fix.


As for increasing the baud rate, I believe that only make communication less reliable. Decreasing the baud rate might improve reliability, but, may be too slow for the application. I also doubt it will help.


I am going to guess the problem is USB 3 over a long cable.



Is this plugged into a USB 3 socket? If you have something suitable, try a USB 2 socket. If the length of the cable is an issue, the slower USB 2 rate might allow it to work.


If you don't have a computer with USB 2, try a USB 2 hub.


Good luck


Philip
Reply With Quote
  #3  
Old 14-05-2024, 07:54 PM
carlstronomy (Carl)
Registered User

carlstronomy is offline
 
Join Date: May 2012
Location: Brisbane
Posts: 461
Philip,

Thanks for the reply, good to see I am not the only one who has had this issue.

I do not think it is the USB 3.0 side. I can run my home made cable using a 2 meter USB 3.0 extension cable. So it must be the speed the signal travels once it has become analogue after the FTDI convertor.

I tried the new cable in a powered hub, usb2 port and usb3 port directly on the computer.

You are correct the baud rate can not be changed, it stopped the computer even seeing the mount on both cables.

I also wonder due to them being a moulded DB9 connector if the pin out is exactly correct for the application we need. I noticed like my home made cable that the real shoestrings are terminated with a non moulded DB9 connector. This makes me think there must be a reason behind the fact they solder their own connections.

More money wasted

Thanks
Carl
Reply With Quote
  #4  
Old 14-05-2024, 10:21 PM
Startrek (Martin)
Registered User

Startrek is offline
 
Join Date: Dec 2017
Location: Sydney and South Coast NSW
Posts: 6,128
Firstly, a few EQDirect cables on the market in recent years have given problems , the only one that hasn’t is Shoestring Astronomy ( Doug ) who are recommended on the EQMOD website.

Secondly , make sure you have the latest drivers installed on your PC / Laptop
Ascom driver 6.6 ( including Microsoft.Net 3.5 framework)
Skywatcher EQ mount driver Prolific PL 2303
Latest version of EQAscom
Latest version of FTDI chipset Windows driver for EQDirect cable
Baud rate should be 9600 for EQ Direct ( USB / USB requires Baud rate of 115200 )

Then next is make sure your your USB Power Management is unchecked in Device Manager ( Windows ) Your computer must not be able to switch off or save power to any USB device connected to it.

Astro Force seems like a third party supplier from China and not one of the most popular choices like Lynx , Pegasus and Shoestring Astronomy

When checking for connectivity …….

Switch on your mount and laptop and open Device Manager in PC/ laptop and verify Com port connection to mount via a serial USB Com port. ( eg COM 3 , COM 5 etc.. ) Unplug cable from mount end to check connection , USB Serial Com ## should disappear. plug it back in and it should reappear.Still in Device Manager select Ports then double click your USB serial Com port and Com port Properties will appear. Go into port settings and ensure Bits per second is 9600 which is Baud rate ( this is very important !!! ) Press ok and close Device Manager.

Also avoid going through a hub ( either powered or unpowered) between laptop and mount.

Another option would be to use the Shoestring Astronomy EQ6 cable ( Available from Bintel ) which is 1.8m long and use a 3m standard USB2 extension cable or a 3m active USB2 extension to reach the mount.

https://www.bintel.com.au/product/sh...eq6-interface/

Other than a dodgy EQDirect cable I can’t think of any other tests and checks to perform

Hope you resolve the issue

Good luck
Martin

Last edited by Startrek; 15-05-2024 at 07:50 AM.
Reply With Quote
  #5  
Old 15-05-2024, 04:28 PM
carlstronomy (Carl)
Registered User

carlstronomy is offline
 
Join Date: May 2012
Location: Brisbane
Posts: 461
Martin,

Thanks for the reply, I have found no issues with my setup. It appears to be a cheap Chinese piece of rubbish cable, non of the legit suppliers are producing long cables obviously because they just do not work correctly. Extending the USB before these cables is the only way to increase the cable length.

What I purchased was listed as a Shoestring cable in the description and they mentioned each cable was checked. I paid $70 for this cable plus postage. I later found the same picture as they used on AliExpress for less than $30 including postage.

Beware, even using some AU astronomy shops.
Reply With Quote
  #6  
Old 15-05-2024, 05:02 PM
Startrek (Martin)
Registered User

Startrek is offline
 
Join Date: Dec 2017
Location: Sydney and South Coast NSW
Posts: 6,128
Quote:
Originally Posted by carlstronomy View Post
Martin,

Thanks for the reply, I have found no issues with my setup. It appears to be a cheap Chinese piece of rubbish cable, non of the legit suppliers are producing long cables obviously because they just do not work correctly. Extending the USB before these cables is the only way to increase the cable length.

What I purchased was listed as a Shoestring cable in the description and they mentioned each cable was checked. I paid $70 for this cable plus postage. I later found the same picture as they used on AliExpress for less than $30 including postage.

Beware, even using some AU astronomy shops.
Thanks Carl,
I since moved on from my older EQ6-R mount back in 2020 to the newer EQ6-R pro mount in Sydney and the newer EQ8-R pro in my NexDome Obs on the South Coast NSW which have the additional USB2B port. Only require a standard USB2 cable ( Startech brand ) from laptop to mount. No need for the FTDI driver , just the Skywatcher PL 2303 driver. A
Cheers
Martin
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 07:28 AM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Advertisement
Bintel
Advertisement
Testar
Advertisement