#1  
Old 24-02-2007, 07:37 PM
leon's Avatar
leon
Registered User

leon is offline
 
Join Date: Apr 2006
Location: ballarat
Posts: 10,825
Any Canon 5D owners

Hi All

Just wondering if any other Canon 5D owners out there have had any problems with their camera

Well mine cracked it today, and decided to die, yep, only 6 months old, although still under warranty, I'm not happy.

Used it today to take some shots for a friend and all was fine until i turned it on again at home and it just wont function.

Tried everything, but to no avail.

When i turn the switch on, the top LCD screen operates and seems OK, but the rest dosn't seem to be getting any power, cannot access the menu, or the images, or settings, and the red light that usually flickers briefly wont come on either.

Battery is full and recharged, and it wont even work on the AC adapter, tried that too, as I thought the battery may have carked it.

Any ideas anyone.

Cheers Leon
Reply With Quote
  #2  
Old 25-02-2007, 08:57 AM
acropolite's Avatar
acropolite (Phil)
Registered User

acropolite is offline
 
Join Date: Feb 2005
Location: Launceston Tasmania
Posts: 8,988
Bummer Leon, better now that when it's out of warranty. Have you tried removing and re-seating the lens and CF card, that can cause problems, although usually just an error message rather than no response.

Last edited by acropolite; 25-02-2007 at 09:23 AM.
Reply With Quote
  #3  
Old 25-02-2007, 09:01 AM
leon's Avatar
leon
Registered User

leon is offline
 
Join Date: Apr 2006
Location: ballarat
Posts: 10,825
Yea Phil, I have tried everything, looks like it has to go to the doctors.

Cheers Leon
Reply With Quote
  #4  
Old 25-02-2007, 09:27 AM
RB's Avatar
RB (Andrew)
Moderator

RB is offline
 
Join Date: Aug 2005
Posts: 22,020
Take out both batteries Leon the main one and the internal backup ( see page 41 in the users manual). Also the CF card and the lens.
Leave the camera without power for a while and then replace them again and see if this resets it back into operation.
Reply With Quote
  #5  
Old 25-02-2007, 06:18 PM
leon's Avatar
leon
Registered User

leon is offline
 
Join Date: Apr 2006
Location: ballarat
Posts: 10,825
Thanks RB, I didnt think of the internal battery

Cheers Leon
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 09:51 PM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Advertisement
EQ8-R
Advertisement
Astromechanics
Advertisement
Star Adventurer
Advertisement
OzScopes Authorised Dealer
Advertisement
Lunatico Astronomical
Advertisement
Celestron RASA
Advertisement
Bintel
Advertisement
Astronomy and Electronics Centre
Advertisement