#1  
Old 29-09-2008, 09:04 PM
StarLane's Avatar
StarLane
Futurist

StarLane is offline
 
Join Date: May 2007
Location: Gold Coast QLD Australia
Posts: 232
Nikon AF-S 28-70mm f2.8 lens question

Hello all,

Just bought a Nikon 28-70 f2.8 lens (second hand) and the lens hood does not attach squarely with the lens and cam body when viewed from the front or back, not side on square.

***Does anyone have this lens and can tell me if this is normal or not???

I have tried to attach it in a few different ways but it always ends up the same when moved around to the lock position, it is not on fully square and needs to move another 5mm or so (to the left when viewed from behind) to achieve a proper fit so everything lines up. When my camera is level on the tripod the hood is up on one side (looks sideways) and the writing on top of the hood in the middle does not line up with the writing on top of the lens. I have another lens (much cheaper) that has the same issue, is this a Nikon thing???? Just doesn't look like it's on properly.

I hope I have described this properly so someone can understand, I can take some photos if needed.

Thanks.
Reply With Quote
  #2  
Old 29-09-2008, 09:35 PM
Ian Robinson
Registered User

Ian Robinson is offline
 
Join Date: Jan 2007
Location: Gateshead
Posts: 2,205
Quote:
Originally Posted by StarLane View Post
Hello all,

Just bought a Nikon 28-70 f2.8 lens (second hand) and the lens hood does not attach squarely with the lens and cam body when viewed from the front or back, not side on square.

***Does anyone have this lens and can tell me if this is normal or not???

I have tried to attach it in a few different ways but it always ends up the same when moved around to the lock position, it is not on fully square and needs to move another 5mm or so (to the left when viewed from behind) to achieve a proper fit so everything lines up. When my camera is level on the tripod the hood is up on one side (looks sideways) and the writing on top of the hood in the middle does not line up with the writing on top of the lens. I have another lens (much cheaper) that has the same issue, is this a Nikon thing???? Just doesn't look like it's on properly.

I hope I have described this properly so someone can understand, I can take some photos if needed.

Thanks.
Ebay ???

Sounds like it was on a camera that has been dropped .... not good.
Reply With Quote
  #3  
Old 29-09-2008, 10:47 PM
StarLane's Avatar
StarLane
Futurist

StarLane is offline
 
Join Date: May 2007
Location: Gold Coast QLD Australia
Posts: 232
No, not dropped, I have finally worked it out.

You really need to force it till it "snaps" into position. I really didn't want to force it with too much pressure but I gave it a go and it worked. Looks like it snaps into place so it doesn't come off even if bumped during a shoot.

Thanks anyway...... I've got it sussed.

PS Beautiful lens.
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 06:34 AM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Advertisement
NexDome Observatories
Advertisement
OzScopes Authorised Dealer
Advertisement
Bintel
Advertisement
Celestron Australia
Advertisement
Meade Australia
Advertisement
SkyWatcher Australia
Advertisement
Lunatico Astronomical
Advertisement
Astronomy and Electronics Centre
Advertisement