#1  
Old 10-04-2006, 07:19 AM
davidpretorius's Avatar
davidpretorius
lots of eyes on you!

davidpretorius is offline
 
Join Date: Jun 2005
Location: Launceston Tasmania
Posts: 7,381
S900NC and raw mode

Quote from Martin Burri

"
Hi all,

having a Philips SPC900nc I did again run some tests.

Drivers: camext40.ax (dll) V 1.3.0.2 (the current one from Philips - no updates since I bought the cam)
You will find it in the Hardware Properties of the camera using the drivers Tab - Details (there's a bunch of files mentioned and one of them is the basic support i.e. the one mentioned above.)

Using the plain cam imaging an LED I've got some well known 'ears' effect
Then I applied the Optimized non raw macro (same as for the 7/840k) and the 'ears' effect is gone.
Also looking at the register setting of the cam there are the same as with the older models.

The only thing that is different and MUST be taken in account is that the SPC900NC has some processing features in the driver that are not known by the older models and that will affact your imaging.

The original camera properties dialog (sometimes called Source) has 3 Tabs - I have only a German version so the naming may vary

Tab 1: General
There's a Zoom and Tracking feature
AND there is the Picture Improvement slider (later more on this one)
Tab 2: Image
There are the well known image properties sliders etc.
Tab 3: Audio
Usually not of much interest.

Now if you use the Optimized Non Raw Macro it is mentioned to reset to factory settings each time before using the cam.
Resetting to factory also affects the Picture Improvement on Tab 1:
So if you switch it off and then press the Factory Reset it is switched on again with a level of about 1/3rd
As it is within the driver software on the PC and not within the cam there is no way to kill this feature using macros.

The good thing is that this setting is also stored when saving your personal defaults.

So I suggest that you reset to factory settings then switch the Picture Improvement off then Save this as Defaults (all in the original Property dialog)
Now you're able to reset to factory (improved) by resetting to the user defaults.

It works also with the 'Load User Settings' button in WcCtrl

So I do currently see no need for new macros it is just to know that this Factory Reset does a bit more than before, alas the Picture Improvement is more subtle than the cam internal sharpening so one could think of playing a bit with this one.
E.g. switch it on and put the slider fully to the left does a kind of blur and will smoothen the colour noise. Some ticks to the right seems to be a neutral position.

Hope it helps

Martin"
Reply With Quote
  #2  
Old 10-04-2006, 08:29 AM
davidpretorius's Avatar
davidpretorius
lots of eyes on you!

davidpretorius is offline
 
Join Date: Jun 2005
Location: Launceston Tasmania
Posts: 7,381
if you have never installed a toucam pro ie Rob_t with his neximage

some new findings by martin:

"
<TT><?xml:namespace prefix = o ns = "urn:schemas-microsoft-comfficeffice" /><o:p>Hi again,</o:p></TT>
<TT><o:p></o:p></TT>
<TT><o:p>due to another mail conversation I think there is a (funny??) issue with the SPC900NC.</o:p></TT>
<TT><o:p></o:p></TT>
<TT><o:p>It could be that if one has never installed a ToUCam Pro (i.e. no such drivers on the system) my progs cannot control the SPC900NC.</o:p></TT>
<TT><o:p>As I always had the old ones installed I never run into this and was not even thinking about such a situation :-/</o:p></TT>
<TT><o:p></o:p></TT>
<TT><o:p>I have to check what will happen when I remove the old drivers - I'll report back here when I now more.</o:p></TT>
<TT><o:p>Unfortunately one is not able to properly install the older ones if not having the Plug n' play mechanism issued by connecting a device that asks for them (at least I assume it)</o:p></TT>
<TT><o:p></o:p></TT>
<TT><o:p>Cheers Martin"</o:p></TT>
Reply With Quote
  #3  
Old 11-04-2006, 07:56 AM
davidpretorius's Avatar
davidpretorius
lots of eyes on you!

davidpretorius is offline
 
Join Date: Jun 2005
Location: Launceston Tasmania
Posts: 7,381
an update
_____________________________


Hi Martin and thank's a lot for testing !!!

Just a question:
Does the ToUcam macros are available directly in WcRmac with a SPC900 connected ?

Best Regards, Etienne )


___________________________________ ________


Hello Etienne,

When you have the ToUCam drivers installed then the Tuc macros are available as the cam is discovered as SAA8116 type
when the ToUCam drivers are not installed then they are not available (but it looks like it defaults to Vesta then - my bug ?)

Cams are controlled through Property Interfaces that are installed on a PC when a device is installed.
Those are supported or not (e.g. a VideoProcAmp is generic one that is installed with Win and most cams do support parts of it)
It seems that the SPC900 supports the Private Property Interface of the ToUCam (the one I know and use)
But it does not install it - so there must be another interface that the SPC900 natively uses - the one I have to discover now :-)

Regards Martin

__________________________________
Reply With Quote
  #4  
Old 11-04-2006, 02:09 PM
Robert_T's Avatar
Robert_T
Registered User

Robert_T is offline
 
Join Date: Oct 2005
Location: Australia
Posts: 2,578
Thanks very much for following this up DP!

I'll have to take time to digest that I don't have right now, but it sounds like I need to have run the macros previously on a Toucam to get them to work on the 900nc?

I had loaded them on my Neximage - wonder if that's meant to count?

cheers,
Reply With Quote
  #5  
Old 11-04-2006, 06:15 PM
davidpretorius's Avatar
davidpretorius
lots of eyes on you!

davidpretorius is offline
 
Join Date: Jun 2005
Location: Launceston Tasmania
Posts: 7,381
quote"
Hello Martin )

Thank's a lot for this new answering.

Ok, so i will add a little text for the SPC900 owners in my RAW webpage, saying that if they had a ToUcam Pro installed on the PC
prior to the SPC900, then they can try the ToUcam Pro macros on the SPC900, and if they have no ToUcam Pro drivers installed, they
must wait for a new version of WcRmac, but the new version will not be easy to make...

BTW, the Vesta Pro macros will not give good results at all with the SPC900 !!!
If the SPC900 user see the 'Restore Original Datas and Factory Settings (for RECENT Vesta's)' in the available macro, then he must
NOT use the macros.

Best Regards, Etienne )"



Basically, if you computer has had a toucam pro installed on it, then installing the 900nc and then the raw mods, it will work.

otherwise no.

I do not believe the neximage will count.

SO Mr ROb, i will burn a copy of the drivers for the toucam and send to you on cd. Uninstall 900nc, then install toucam, install 900nc and then run the wrmac for raw modes.

Rocket Boy, have you had a toucam???
Reply With Quote
  #6  
Old 18-04-2006, 09:22 PM
spacezebra's Avatar
spacezebra (Petra)
Lost in Namibia

spacezebra is offline
 
Join Date: Aug 2005
Location: Albury NSW
Posts: 3,097
Hi David P

Can you post a pic on how your web cam is attached - just curious.

Cheers Petra
Reply With Quote
  #7  
Old 19-04-2006, 06:50 AM
davidpretorius's Avatar
davidpretorius
lots of eyes on you!

davidpretorius is offline
 
Join Date: Jun 2005
Location: Launceston Tasmania
Posts: 7,381
hi,

to the computer or telescope?
Reply With Quote
  #8  
Old 19-04-2006, 04:39 PM
spacezebra's Avatar
spacezebra (Petra)
Lost in Namibia

spacezebra is offline
 
Join Date: Aug 2005
Location: Albury NSW
Posts: 3,097
Sorry Dave

Should have been clearer - to the telescope.

Cheers
Petra
Reply With Quote
  #9  
Old 19-04-2006, 05:39 PM
davidpretorius's Avatar
davidpretorius
lots of eyes on you!

davidpretorius is offline
 
Join Date: Jun 2005
Location: Launceston Tasmania
Posts: 7,381
will do tonight while it is raining!
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 09:19 PM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Advertisement
Lunatico Astronomical
Advertisement
SkyWatcher Australia
Advertisement
Bintel
Advertisement
Meade Australia
Advertisement
Celestron Australia
Advertisement
OzScopes Authorised Dealer
Advertisement
NexDome Observatories
Advertisement
Astronomy and Electronics Centre
Advertisement