#1  
Old 12-12-2017, 01:28 PM
glend (Glen)
Registered User

glend is offline
 
Join Date: Jun 2013
Location: Lake Macquarie
Posts: 5,287
ASI1600MM-C Servicing

So i have started to have some fan vibration issues with my 1600MM-C camera, the fan has visible dust building up and the fan guard is rusting, and the USB3 port on the camera is a bit loose. The vibration was so bad last night that i could feel it through the guidescope, so it was transmitting through the APO. This camera was one of the first delivered by Bintel (late May 2016) and it has a lot of hours on it, considering all the subs i have shot. I think it needs a service. I rang Don at Bintel and he suggested sending it back to him and then he will send it on to ZWO, but obviously in the new year now given Christmas.

Has anyone returned a 1600 for service? Was there a cost involved considering they are all still under warranty?
I could probably take the back off and clean the fan blades, but the guard still should be replaced and i would want the USB3 port replaced as well. Anyone doing their own servicing?
Reply With Quote
  #2  
Old 12-12-2017, 07:34 PM
SteveInNZ
Registered User

SteveInNZ is offline
 
Join Date: May 2008
Location: Auckland, NZ
Posts: 211
I had problems with mine and after a screen share to confirm that the problem was with the camera, they sent an RMA and I sent it back for repair.
They had it for four weeks.

Steve.
Reply With Quote
  #3  
Old 12-12-2017, 10:38 PM
luka's Avatar
luka
Unregistered User

luka is offline
 
Join Date: Apr 2007
Location: Perth, Australia
Posts: 1,090
Glen, if you decide to do anything yourself make sure it does not void the warranty.

You may be able to blow the dust out with compressed air, just make sure you don't let the fan spin too fast or it may damage the bearings.
Reply With Quote
  #4  
Old 12-12-2017, 11:01 PM
glend (Glen)
Registered User

glend is offline
 
Join Date: Jun 2013
Location: Lake Macquarie
Posts: 5,287
Quote:
Originally Posted by luka View Post
Glen, if you decide to do anything yourself make sure it does not void the warranty.

You may be able to blow the dust out with compressed air, just make sure you don't let the fan spin too fast or it may damage the bearings.
Yeah i have thought about it, you know me, i don't mind getting stuck into camera mods. But the smart thing to do is to return it to Bintel and Don sends it to Sam at ZWO. Its still under warranty i think (2 years). I know i will have to pay shipping but beyond rhat i can't say what their policy is on servicing.
Reply With Quote
  #5  
Old 12-12-2017, 11:09 PM
luka's Avatar
luka
Unregistered User

luka is offline
 
Join Date: Apr 2007
Location: Perth, Australia
Posts: 1,090
Quote:
Originally Posted by glend View Post
Yeah i have thought about it, you know me, i don't mind getting stuck into camera mods.
That's why I said to watch out for the warranty

Maybe email ZWO and see what they say and how long it will it take.
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 02:26 AM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Advertisement
NexDome Observatories
Advertisement
Meade Australia
Advertisement
Bintel
Advertisement
Lunatico Astronomical
Advertisement
SkyWatcher Australia
Advertisement
Celestron Australia
Advertisement
OzScopes Authorised Dealer
Advertisement
Astronomy and Electronics Centre
Advertisement