#1  
Old 07-07-2013, 06:18 PM
stanlite (Grady)
Registered User

stanlite is offline
 
Join Date: Jan 2010
Location: Brisbane
Posts: 344
Issue with QHY8L TEC cooler

Hello all was wondering if anyone here has had a similar issue or might know a solution.

My QHY8L CCD has stoped cooling. The TEC turns on and the fan in the device starts spining but one of two things happens. Either the temp control program states the the temp is 100 degrees and doesn't show the current draw. OR the temp shows as ambient but the current draw doesn't increase to increase the cooling (stays at 1%)

I have been using Sequence Generator Pro although the results are replicated in Ezycap.

I am always careful when unpluging the camera, always warm it up to avoid thermal shock and always cut power to the TEC before disconnecting from the laptop. Any clues as to what it could be, i have a sinking feeling that this meant the peltiar or TEC is fried.
Reply With Quote
  #2  
Old 07-07-2013, 07:43 PM
Visionoz's Avatar
Visionoz (Bill)
Registered User

Visionoz is offline
 
Join Date: Oct 2008
Location: Perth, Western Australia
Posts: 714
Probably best to contact Theo - from Gama Electronics - the Ozzie local distributor

HTH
Cheers
Bill
Reply With Quote
  #3  
Old 09-07-2013, 08:53 AM
graham.hobart's Avatar
graham.hobart (Graham stevens)
DeepSkySlacker

graham.hobart is offline
 
Join Date: Nov 2008
Location: hobart, tasmania
Posts: 1,973
qHY 8

Theo is very helpful. On the other hand if the TEC is gone (like mine did) he would sent it to QHY for a repair anyway ( I think)- so you could just contact them directly.They have a ticket repair system on the website and it worked well for my repair.
Hopefully it's not a grave issue!
Graham
Reply With Quote
  #4  
Old 09-07-2013, 11:15 AM
nate_b
Registered User

nate_b is offline
 
Join Date: Feb 2010
Location: Pittsburgh, PA
Posts: 1
I had the same thing happen with my original QHY8; failed TEC. I put in a help ticket with QHY and had a prompt response. I could send it back to China for repair or they would send me a new heat sink / TEC assembly and I could install it myself. I did the install without a problem and the cost was fairly reasonable.
Reply With Quote
  #5  
Old 12-07-2013, 05:58 AM
cybereye's Avatar
cybereye (Mario)
Mozzies love me!

cybereye is offline
 
Join Date: Aug 2009
Location: Brisbane
Posts: 1,277
I'd contact Theo first - as an owner of a QHY8L I'll be watching this thread with interest...

Cheers and good luck,
Mario
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 07:52 PM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Advertisement
Meade Australia
Advertisement
Bintel
Advertisement
NexDome Observatories
Advertisement
SkyWatcher Australia
Advertisement
Celestron Australia
Advertisement
OzScopes Authorised Dealer
Advertisement
Lunatico Astronomical
Advertisement
Astronomy and Electronics Centre
Advertisement