#1  
Old 03-05-2013, 07:12 PM
kinetic's Avatar
kinetic (Steve)
ATMer and Saganist

kinetic is offline
 
Join Date: Jun 2008
Location: Adelaide S.A.
Posts: 2,260
File format RGB FITS HELP!

Last night I was well out of my comfort zone....
I imaged with an OSC!!!!!!!!!!!!!!!!!!! a Meade DSI II colour CCD.
The trouble was, I didn't check what format Nebulosity was saving my files.
It saved (by default) in RGB FITS.

In hindsight, RAW FITS would have been better.
So, after several beers my hazy recollection of RGB reconstruction all
went to sh$#.

After calibrating out a master dark and then debayering I have no colour!
Where did the colour go?
After extreme saturation I can get some colour but I'm puzzled as to
why it is so washed out in the stack result before curves?

I don't have any of this trouble with the QHY8 OSC processing.

Then why the DSI II colour?

Hmmm...maybe colour aint my thing.

I thought I had a ball tearer set of colour to add to my mono full res set.
If I can't work this out it will have to be 3 more good nights with the mono CCD and filters.......

Ahh...back to my beer
Attached Thumbnails
Click for full-size image (rough_debayer.jpg)
105.1 KB17 views
Reply With Quote
  #2  
Old 03-05-2013, 08:47 PM
whzzz28's Avatar
whzzz28 (Nathan)
Registered User

whzzz28 is offline
 
Join Date: Dec 2011
Location: Brisbane
Posts: 341
Not sure if related, but your background and most likely whites are clipping. This means lost data and as star colors are generally in the upper white areas, you lost most of it. Make sure you use curves for pulling data out and only use the black level in histograms to get remove blackspace.

Are you able to throw up a copy of the stacked FITS file? Will probably give a better understanding of whats going on.
Reply With Quote
  #3  
Old 04-05-2013, 01:34 PM
kinetic's Avatar
kinetic (Steve)
ATMer and Saganist

kinetic is offline
 
Join Date: Jun 2008
Location: Adelaide S.A.
Posts: 2,260
Sure Nathan,

a few details:

Outside Observatory Neb program is set to save as RGB FITS (default)

A single sub from the DSI II colour is 1.691Mb 748p x 577p (RGB FIT)
pixels are NOT SQUARE, they are 8.6um x 8.3um.

A single sub put thru a debayer (best quality square) is 773p x 575 p
(see how image info is now colour=1 and pixels have been squared to 8.3um x 8.3um)

A stack result FIT is 2.852Mb and813p x 598p (RGB FIT)

A master dark ( a dark made from 150 dark frames) is 847kb and 748p x 577p

So, I think my sequence should be:

Subs treated as mono (not debayered yet, even though the file is
saved as an RGB FIT.

Darks treated as mono (not debayered yet, same, saved as RGB FIT)

1. subtract master dark from subs.
2. apply a bad pixel map to calibrated subs.
3. stack.
4. debayer result

???

I do this and I get NO colour.

Steve
Attached Thumbnails
Click for full-size image (single_original_frame.jpg)
138.9 KB1 views
Click for full-size image (sub_debayer_square_saturationx3.jpg)
69.1 KB2 views
Reply With Quote
  #4  
Old 04-05-2013, 01:50 PM
multiweb's Avatar
multiweb (Marc)
ze frogginator

multiweb is offline
 
Join Date: Oct 2007
Location: Hinchinbrook
Posts: 18,138
Hey Steve, can you post a link to one of the FIT subs out of the cam? Will have a peek.
Reply With Quote
  #5  
Old 04-05-2013, 01:54 PM
kinetic's Avatar
kinetic (Steve)
ATMer and Saganist

kinetic is offline
 
Join Date: Jun 2008
Location: Adelaide S.A.
Posts: 2,260
Do you want a raw full sized FIT, Marc?
if so, hang on, I'll try and FTP one up to IIS.

edit: damn...Mr S changed the pw...........

This might give away my problem....here is a stack of debayered subs
with NO DARKS subtracted....
See the 3 peaks in the histo, does that mean I'm almost there but just need to scale my colours?

Steve
Attached Thumbnails
Click for full-size image (stack_of_debayered_subs_no_darks.jpg)
51.5 KB8 views
Reply With Quote
  #6  
Old 04-05-2013, 02:20 PM
multiweb's Avatar
multiweb (Marc)
ze frogginator

multiweb is offline
 
Join Date: Oct 2007
Location: Hinchinbrook
Posts: 18,138
Quote:
Originally Posted by kinetic View Post
Do you want a raw full sized FIT, Marc?
if so, hang on, I'll try and FTP one up to IIS.

edit: damn...Mr S changed the pw...........

This might give away my problem....here is a stack of debayered subs
with NO DARKS subtracted....
See the 3 peaks in the histo, does that mean I'm almost there but just need to scale my colours?

Steve
Yeah if you could RAR one unbinned FIT with the bayer matrix intact. Just wanna check why you're not getting any colour. If it's too big just crop a bit but don't resize or bin anything. Or PM link or email file. Doesn't matter what size. If you can send it I can take it.
Reply With Quote
  #7  
Old 04-05-2013, 02:28 PM
kinetic's Avatar
kinetic (Steve)
ATMer and Saganist

kinetic is offline
 
Join Date: Jun 2008
Location: Adelaide S.A.
Posts: 2,260
ok here is a FIT crop of sub #9....


I hope I can attach FITS.......NOPE

Try Zip....yep
Attached Files
File Type: zip crop_sub9.zip (17.7 KB, 4 views)
Reply With Quote
  #8  
Old 04-05-2013, 07:15 PM
multiweb's Avatar
multiweb (Marc)
ze frogginator

multiweb is offline
 
Join Date: Oct 2007
Location: Hinchinbrook
Posts: 18,138
I was able to debayer RGGB to color. I think the FIT header doesn't show bayer. It has an entry that says '/ Optical filter name' instead.
Attached Images
 
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 04:38 AM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Advertisement
SkyWatcher Australia
Advertisement
OzScopes Authorised Dealer
Advertisement
Bintel
Advertisement
NexDome Observatories
Advertisement
Meade Australia
Advertisement
Lunatico Astronomical
Advertisement
Celestron Australia
Advertisement
Astronomy and Electronics Centre
Advertisement