#1  
Old 21-02-2019, 10:44 PM
kljucd1's Avatar
kljucd1 (Daniel)
Registered User

kljucd1 is offline
 
Join Date: Sep 2007
Location: Gledswood Hills, Australia
Posts: 276
Weird red pixels

I keep on getting these weirdly shaped pixels when trying to do widefield. While I don't yet understand 100% the whole stacking darks process, I have tried this and it doesn't process out these pixels. They are always red. In fact for most of my images the - for lack of a better term - noise is often mostly red.

I discarded the astro widefield images where I was getting this but I have attached a scaled down copy of an original image from some ISO testing I was doing tonight - what else is there to do when it's raining - as well as a zoomed in snip of the original.

The camera is a Pentax K20D. Often, when I get this issue, I am using my Pentax 17-70 SDM lens or a Tamron SP AF Di 90mm Macro. While I don't usually get such pronounced red pixels when using my SW ED80 Pro/WO ZenithStar 66 the red noise issue usually shows up. In all cases we are talking exposure times of ~5-30 seconds.

Hopefully I have included enough information?
Attached Thumbnails
Click for full-size image (weird pixels.JPG)
45.3 KB37 views
Click for full-size image (IMGP3610 plus3v2.jpg)
73.0 KB36 views
Reply With Quote
  #2  
Old 21-02-2019, 10:45 PM
bojan's Avatar
bojan
amateur

bojan is online now
 
Join Date: Jul 2006
Location: Mt Waverley, VIC
Posts: 5,661
Those are hot pixels..

You need to use darks to get rid of them...



BTW, could it be radioactive glass?


Red halo looks like it's caused by chromatic aberration...


EDIT: Originally I mentioned "flats" instead of "darks"... what I have been thinking ?

Last edited by bojan; 22-02-2019 at 07:07 AM.
Reply With Quote
  #3  
Old 22-02-2019, 06:54 AM
kljucd1's Avatar
kljucd1 (Daniel)
Registered User

kljucd1 is offline
 
Join Date: Sep 2007
Location: Gledswood Hills, Australia
Posts: 276
Thanks for the link it has a bunch of useful information, funnily enough

I'm not sure about whether the glass is radioactive. Is there an easy way to tell? It doesn't have the yellow tinge the glass on my old super takuma 50mm has. I googled it and couldn't find any information.
Reply With Quote
  #4  
Old 22-02-2019, 07:08 AM
glend (Glen)
Registered User

glend is offline
 
Join Date: Jun 2013
Posts: 5,187
Flats may not be necessary, being more useful for dirty optics, filter artifacts, etc. If you use DSS for stacking there are option boxes to tick for hot/cold pixel removal. You do need to use Bias and Darks.
Reply With Quote
  #5  
Old 22-02-2019, 07:12 AM
bojan's Avatar
bojan
amateur

bojan is online now
 
Join Date: Jul 2006
Location: Mt Waverley, VIC
Posts: 5,661
Quote:
Originally Posted by glend View Post
Flats may not be necessary,......
Yep, I corrected myself in my post... I was thinking darks, but typed flats
Reply With Quote
  #6  
Old 22-02-2019, 07:41 AM
Sunfish (Ray)
Registered User

Sunfish is offline
 
Join Date: Mar 2018
Location: Wollongong
Posts: 254
On my Pentax KS2 I can run a hot pixel check and the camera updates and removes them automatically. I saw the same thing until I removed them this way and then do an update occasionally. Check the manual.
Reply With Quote
  #7  
Old 22-02-2019, 10:22 AM
sil's Avatar
sil (Steve)
Not even a speck of dust

sil is offline
 
Join Date: Jun 2012
Location: Canberra
Posts: 1,265
having the camera make adjustments is not desirable ever. proper preprocessing with darks and bias frames etc is better and more accurate without adding extra artifacts to the images.
Reply With Quote
  #8  
Old 22-02-2019, 11:58 AM
Sunfish (Ray)
Registered User

Sunfish is offline
 
Join Date: Mar 2018
Location: Wollongong
Posts: 254
I am not sure the camera altering the image file in this case. It simply turns off recording of any pixels which are faulty by in camera testing and passes that information to the image processing software as far as I know. Fairly standard practice for any DSLR. Happy to be corrected by anyone who has more actual informed and detail knowledge of DNG files and their complexities.

Even long shutter speed noise reduction which applies a matching dark frame for each shot works just as well as DSS I think if you are patient. All other adjustments I turn off but some still use in camera high iso noise reduction at low level. Depends a lot I think on the camera and itís sensor and systems.
Reply With Quote
Reply

Bookmarks

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time is now 02:24 PM.

Powered by vBulletin Version 3.8.7 | Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Advertisement
Bintel
Advertisement
Meade Australia
Advertisement
Lunatico Astronomical
Advertisement
NexDome Observatories
Advertisement
OzScopes Authorised Dealer
Advertisement
SkyWatcher Australia
Advertisement
Nitecore
Advertisement
Astronomy and Electronics Centre
Advertisement