View Single Post
Old 23-10-2012, 11:09 AM
AstralTraveller's Avatar
AstralTraveller (David)
Registered User

AstralTraveller is offline
Join Date: Mar 2008
Location: Wollongong
Posts: 3,654
Canon 400D not releasing


I wondering whether anyone else has experience the same issue as me?

I'm running a 600D with a 400mm lens and a 400D with a 200mm lens, both controlled by EO. My sequence starts with the 600D, then does a block with the 400D and then returns to the 600D before third contact. The software is running under Win XP and works pretty well. It tends to drop the first shot after each camera change and lengthening the delay doesn't seem to help. So that's perhaps two shots out of 70 that are lost. I can live with that.

Last night I tried the same script on a friend's machine (which will be the backup) running Win 7 and had real problems. The change from the 600D to the 400D works OK but the change from the 400D back to the 600D freezes the script. When the 400D is taking shots you can see the red light on the back which indicates that it is busy writing to memory come on after each shot for 1.5-2 sec. However, after the final shot it comes on and stays on. In EO the status of the 600D is shown as 'waiting on another camera' (or similar - it's not in front of me) and remains that way. This can continue for at least several minutes (the limit of my patience). If I unplug the 400D the 600D resumes taking shots. I tried the XP box again and it still works OK. We tried the upgrade and it made no difference.

I'm thinking it might be driver related but that's about the limit of my knowledge. I'm going to file a bug report but I believe there are a few bug reports being submitted at the moment. In the meanwhile has anyone else experience this problem and have you solved it?

BTW my best solution so far is to have a voice prompt to unplug the 400D immediately after its block.
Reply With Quote