View Single Post
  #505  
Old 14-01-2017, 11:15 PM
luka's Avatar
luka
Unregistered User

luka is online now
 
Join Date: Apr 2007
Location: Perth, Australia
Posts: 1,136
Gilles, got the driver working on Beaglebone Black. Few observations:
1. The lines are really bad, present in every image. Quite often it is not just lines but "blocks" of "misplaced" data showing vertical artifacts.

2. Acquisition is very slow. After the exposure it does
...
Try 2000 since 11778624<>12008000
for few seconds and then it takes few seconds again to transfer the image. I timed 15 seconds to take, transfer and show 1s exposure.
edit: for comparison taking and showing 1s exposure on my PC takes 5 seconds.

3. The CPU usage is 100% for several seconds. This seems to be part of the bottleneck. Only one CPU core is used at time. Firstly ./indi_cam86_ccd takes 100% of the CPU (image processing?) and then indiserver does (image transfer?).

Have you tried using the driver on a Raspberry Pi yet? The lines are present in almost every image on the BeableBone Black and they probably will be on Raspberry Pi as well. This may make it easier to tweak the FTDI parameters. I tried changing the parameters and at one stage got few good images but the same parameters did not work few minutes later. There is something weird going on.

Also what do lines like this mean?
Try 2000 since 11778624<>12008000
Reply With Quote