View Full Version here: : Ultima 2000 tracking

17-09-2017, 02:32 PM
I have an Ultima 2000 SCT. How do I get it to track correctly for the Southern Hemisphere? At power up, the telescope tracks backwards!

I have tried holding down the UP and Down button at power up.

17-09-2017, 03:28 PM
hi there Doug
do you have it set up on a EQ wedge ? if to there is a menu in the hand box that is called TRACKING in that menu is options of setting your tracking e.g.
tracking off , Alt Az , eq north , Eq south this is the option you want
hope this helps
cheers Pete

17-09-2017, 07:10 PM
Hi Spiezzy,

no, I don't have the Ultima on an equatorial wedge. It (of course) uses Alt-Az tracking without the wedge.

Thanks for your input. I am selling the telescope as part of a deceased estate otherwise I could knock-up a wedge and that would certainly be a good outcome.


19-09-2017, 01:25 AM

I've never had an issue with my U2K tracking incorrectly in Alt-Az mode.

A couple of questions...

1) Does the scope slew in the correct direction when the keys are pressed?
2) When you do the alignment, what Warp Factor, W, do you get? It should be less than 0.6. Anything bigger and the scope gets "lost".
3) Are you using the original cable from the base to the handset?

Lastly, what are you asking for the scope?


20-09-2017, 10:14 AM

I was recently in Laramie! I came to Wyoming to view the total eclipse on august 21 and I leased a house in Laramie for four days: what a co-incidence? My group then drove to Glenrock (having set out for Casper) but decided that Glenrock was a better site. We viewed the eclipse in clear skies from the local showground but had to endure the traffic bottleneck on the way back down the I-25 to Cheyenne and Laramie! It took us 9 hours!!!!

I shall answer your queries later when I am back at home.


21-09-2017, 12:16 AM
Cool.. glad you enjoyed the eclipse. I just moved to Laramie on August 1st from Adelaide... spent 13 years in Australia, 19 years away from the USA. I'm glad to be back, even though all I hear are strange accents... ha ha

If I recall, I believe you upgraded the handset to the Y2K chip from Anthony Mitchell. Have you tried the old chip to see if your scope tracks correctly? Let me know how you go.

Also, I'm interested in it, so let me know if/when you want to sell it and what the estate would like for it. I've got a son in Sydney who could take delivery. I'm really more interested in the OTA, but realize that the estate would probably prefer the purchase as a unit.