PDA

View Full Version here: : Vixen SXW and sky safari, I am stumped, any help appreciated


Gallifreyboy
12-08-2017, 05:54 PM
Long time since I have been active here, about 5 years. The astronomy bug has bitten again and have dusted off some of the equipment.
I have updated the Vixen SXW Star Book to the latest firmware 2.7
Entering the date correctly i.e Aug 2017 the Star Book freezes, no buttons respond after you hit OK, I thought I had corrupted the update so redid it 3 more times, same problem, I could still do the date at setup before I hit OK and on a whim entered the year as 2015 and it works normally, I have got up to 2016 and it works but 2017 will not.
No worries I thought, I never liked the star book very much any way, I read some people have got it working via sky safari and thought that would overcome the problem.
The instructions seemed easy enough to follow, not as straight forward as the skywire or skyfi option as vixen has a non-standard serial port but get a wireless router hooked up and LAN cable to your Star Book (cable in where it says LAN on the bottom of the Star Book)
In sky safari the setup IP address for Star Book entered 169.254.1.1
Port Number 80 (I read that is what it should be)
The wireless router is the TPLINK AC750 travel router (can be run off 5V USB outlet)
I have configured the LAN address to 169.254.1.10 although have tried 169.254.1.100 and 169.254.1.2 without any success.
So far this has been very frustrating so anybody who could help would be greatly appreciated (mainly the sky safari issue but including the 2017 bug)

rrussell1962
12-08-2017, 06:44 PM
Is the 169.254.1.1 IP address what comes up as the IP address in the System menu on the Starbook? Also have you tried doing a mock alignment then connecting to LAN? What else, oh yes, LAN cable needs to be straight through not crossover.

Gallifreyboy
12-08-2017, 09:47 PM
Yes that is the Star Book IP address, have tried several cables all look to be straight through too, still no luck, thanks though, tried it after alignment too

issdaol
13-08-2017, 09:15 AM
Sounds like you may have a problem with your Starbook after the update.

I have the SXW and it works ok with current dates.

In terms of the Wireless you have to make sure that your WIFI Router is setup to give IP address via DHCP so your Laptop/Ipad/Iphone and Starbook are all communicating on the same IP network

Gallifreyboy
13-08-2017, 12:40 PM
Thanks Phil, I suspect there is something funny after the update, 2016 works but not 2017.....I have played with every combination possible on the wireless router I can think of too...sometimes obviously wrong settings give an immediate cannot connect message from sky safari, ones that should work take 10-15 seconds before the cannot connect message

issdaol
14-08-2017, 07:15 AM
Yes definitely sounds like the Starbook.

You should not have to fiddle with IP settings at all....

Once DHCP is setup once on the router and and your devices get their IP addresses from DHCP, all you then need to do is tell SkySafari that you are using a Starbook and point it at the IP address of the StarBook.

I have never had to do a complete reset of my Starbook to factory, but sounds like this is what you may have to do.

I know for sure that I am able to enter 2017 dates in mine as I did so a couple of months ago after I had let the battery drain lol

LewisM
14-08-2017, 08:51 AM
Phil is right - sounds like the Starbook has gone screwy. I updated all my Starbooks after the latest release (I had 2 at the time, only 1 now), and I still use my Starbook today on my SXW without issue. I even updated the one I sold Phil, so I know he's not talking horse nuggets as he usually does :) :P :lol:
I have the WIFI box too, but honestly don't feel the need, as the Starbook does everything I want easily. Phil just does it because he's a techno-junkie :)

Reset the Starbook to factory, then reinstall the update. I just plugged mine in and checked the date, and it is correct, and 2017. Also, but not sure, perhaps you may need to change the Starbook's internal battery too - that may be on it's way out.

Gallifreyboy
14-08-2017, 02:03 PM
I think I will have to do a factory reset but I can't find any specific instructions on how to do it, any ideas?

LewisM
14-08-2017, 02:58 PM
A couple of guides:

http://www.vixenamerica.com/technical/techdoc_starbookupdates.asp

https://www.vixen.co.jp/en/at/update/sb.html

https://www.vixenoptics.co.uk/PDFs/User%20Guides/SX_SXD_User_Guide.pdf

LewisM
14-08-2017, 03:04 PM
I may be selling my SXW soon in a mount upgrade :P

It'll be $1K posted...(complete mount, tripod, Starbook etc)

Gallifreyboy
14-08-2017, 03:19 PM
Thanks Lewis, I have been using the Japanese site, reading the US site it makes a big point of using crossover cable, mine has been straight through, I am hoping it is as simple as reinstalling with correct cable, still not sure how to do a factory reset if that doesn't work, it says if update corrupts a programme to take to nearest dealer....being in Perth that is not going to be an option

LewisM
14-08-2017, 06:35 PM
Vixen won't work on the Starbook now anyway, so you need to do it yourself.

As far as I know, the SXW is out of production, the Starbook has been OOP for a while, and spares for the SXW are getting hard to get (the ORIGINAL Starbook, not the One or TEN). I recently ordered a full set of the plastic parts, and have a spare dec head, so I suggest if you keep the mount, buy spares NOW. I did for my GPD's, and do NOT regret it, because parts now are IMPOSSIBLE unless you find a donor mount (I bought every conceivable spare, and it came in VERY handy when Aus Post decided to bend and bugger a GPD I bought).

I believe there is only ONE authorised Vixen dealer in Australia now too and that is Steve Massey at myastroshop.com.au